Jump to content


Photo

Avactis 2.1 Released!


  • Please log in to reply
97 replies to this topic

#1 Oleg

Oleg

    Avactis Team Member

  • Administrators
  • PipPipPipPipPipPip
  • 510 posts

Posted 01 March 2011 - 12:16 PM

New in Avactis 2.1:

- Major performance optimizations.
We have significantly upgraded the Avactis Shopping Cart performance. Avactis 2.1 is distinctly faster, which is important for websites with large catalogues.

- Avactis 2.1 is preinstalled on a new server.
Avactis servers provide the best performance for websites selling thousands of products. The latest project has 50,000 products in its catalogue.

- Improved top menu in admin panel.
The new menu is more user-friendly.

menu.png

- New Avactis modules can be installed with Avactis 2.1.
We have launched a number of modules that can be purchased separately. Three modules are now available on the Avactis website, and more are coming soon. These modules can be installed on the Avactis 2.1 version by simply copying files.

- Custom Checkout fields in Notifications.
You can insert Custom Checkout fields in email notifications.

- Multi-language support for Tax Display options.
- PayPal Pro Signature.
- Cross Site Request protection.
- Storefront Ajax modules support.

Improvements:

- CSS Editor: new rules for editing of some page elements.
- Display of 'no image' picture in default skins.
- Customer Reviews feature now uses Ajax.
- Shipping Cost Calculator now uses Ajax.
- Sign-in Box now uses Ajax.

Bug fixes:


We have successfully solved the issues with:

- OneStepCheckout
- Reset of Credit Card Information during checkout
- Promo Codes
- Product Options, Inventory Tracking
- Order search by an Affiliate ID
- Order display in Admin Area
- Gift Certificates
- Saving information for reports
- USA ePay
- Customer Groups
- Credit Card Info encoding



#2 BradE

BradE

    Novice

  • Members
  • PipPip
  • 14 posts

Posted 01 March 2011 - 12:19 PM

How can I get access to the 2.1 White Label download? Thank you

#3 Ilya Vassilevsky

Ilya Vassilevsky

    Avactis Support

  • Administrators
  • PipPipPipPip
  • 198 posts

Posted 01 March 2011 - 12:46 PM

We can send the download link to your e-mail address :) (already did)

#4 ava2011

ava2011

    Novice

  • Members
  • PipPip
  • 27 posts

Posted 01 March 2011 - 02:22 PM

Is there a reason why those who bought Avactis 2.0 did not receive an email about the new release ? Where can I download the new release ? What are the steps to take to go from 2.0 to 2.1 ? I saw a post that the 2.1 database is not compatible with 2.0 database. Is this true ?

#5 Jules

Jules

    Novice

  • Members
  • PipPip
  • 13 posts

Posted 01 March 2011 - 04:16 PM

I have the same questions as the above post! I like the new module features and would like to be able to take advantage of them before the special price ends. INQUIRING MINDS WANT TO KNOW, HOW DO WE UPGRADE FROM 2.0 TO 2.1 AND QUICK!!!!!! :lol:

Is there a reason why those who bought Avactis 2.0 did not receive an email about the new release ?

Where can I download the new release ?

What are the steps to take to go from 2.0 to 2.1 ?

I saw a post that the 2.1 database is not compatible with 2.0 database. Is this true ?



#6 Oleg

Oleg

    Avactis Team Member

  • Administrators
  • PipPipPipPipPipPip
  • 510 posts

Posted 02 March 2011 - 10:38 AM

Where can I download the new release ?


If you already have a license, you can request 2.1 installation package here:
https://www.avactis....ort.php?dl=inst

#7 John Thompson

John Thompson

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 02 March 2011 - 02:07 PM

Is there an upgrade path from 1.8.1 to 2.1 directly or do I need to upgrade from 1.8.1 to 2.0 and then again to 2.1? Is there an upgrade from 2.0 to 2.1 or does 2.1 need to be a fresh installation? Also, are there instructions for migrating the catalog and settings into a fresh install of 2.1?

#8 Oleg

Oleg

    Avactis Team Member

  • Administrators
  • PipPipPipPipPipPip
  • 510 posts

Posted 03 March 2011 - 08:22 AM

Avactis 2.1. update utility is already developed, our QA department tests it currently.

#9 DonH

DonH

    Overlord

  • Members
  • PipPipPipPipPipPipPip
  • 1,019 posts

Posted 03 March 2011 - 10:00 AM

I received the newsletter today. Following the Order Update Service link, I see updates from all versions up to 1.91, but not 2.0. Around Feb 20, I installed what I requested a fresh version to install. I used a new database for the install and then changed the configuration files to point to the existing 2.0 database. Several issues required urgent messages to support, who told me that I needed to change the files back to 2.0 until the conversion program was released. So...what is the 2.0 -> 2.1 upgrade path??

#10 Oleg

Oleg

    Avactis Team Member

  • Administrators
  • PipPipPipPipPipPip
  • 510 posts

Posted 05 March 2011 - 05:41 AM

Is there an upgrade path from 1.8.1 to 2.1 directly or do I need to upgrade from 1.8.1 to 2.0 and then again to 2.1?


You will be able to upgrade directly from 1.8.1.

I received the newsletter today. Following the Order Update Service link, I see updates from all versions up to 1.91, but not 2.0. Around Feb 20, I installed what I requested a fresh version to install. I used a new database for the install and then changed the configuration files to point to the existing 2.0 database. Several issues required urgent messages to support, who told me that I needed to change the files back to 2.0 until the conversion program was released. So...what is the 2.0 -> 2.1 upgrade path??



Update:
Avactis 2.0 -> 2.1 update utility will be published the next week.


If you like you can purchase update service at: https://www.avactis....#step-1/support
Choose "Update from versions 1.9.0, 1.9.1, 2.0.0" option from the Update Service list.

#11 Jodes

Jodes

    Novice

  • Members
  • PipPip
  • 34 posts

Posted 05 March 2011 - 10:47 PM

Update:
Avactis 2.0 -> 2.1 update utility will be published the next week.


am I reading this correctly? I can't upgrade my full (owned) Avactis 2.0 - 2.1 until the update utility is published?

I can (and have) requested 2.1 via the support link - Is this for a complete fresh install? (not an upgrade from 2.0 - it does say don't install over your existing store)

Mind you, I don't mind starting from scratch again (using the first as a practise run LOL) as I still have a lot of work to do on it. Thinking the 2.1 might make life easier in the long run by doing a fresh install.

However, reading over some other posts... and the amount of time I put in setting up postage, modifying email notifications etc. updating might be the go?

hmmmm - wait for updater or do a clean install????

#12 DonH

DonH

    Overlord

  • Members
  • PipPipPipPipPipPipPip
  • 1,019 posts

Posted 06 March 2011 - 10:39 AM

The 2.1 that you downloaded is for a clean install. There are enough differences in the database that you can't simply install the new files and connect to the 2.0 database. The upgrade utility, not only updates the appropriate files, it updates the database so that your existing settings, products, etc., remain. In your situation, it might make sense to install 2.1 in a separate directory and new database, keeping the original 2.0. You could "play" with 2.1 to see if it makes more sense to start over or wait for the update utility. By keeping both, you keep your options open and you can toggle back and forth, should you decide to start over, making it easier to "remember" what you did.

#13 Jodes

Jodes

    Novice

  • Members
  • PipPip
  • 34 posts

Posted 06 March 2011 - 05:08 PM

ahhhh that sounds like a very good idea. Thanks for that.

#14 Oleg

Oleg

    Avactis Team Member

  • Administrators
  • PipPipPipPipPipPip
  • 510 posts

Posted 10 March 2011 - 09:41 AM

Avactis 2.1 update utility is available for download.
You can request it here:
https://www.avactis....port.php?dl=upd

If you like our supporters can update your store for you,
you can purchase update service here:
https://www.avactis....#step-1/support

Feel free to contact us.

#15 bondpix

bondpix

    Enthusiast

  • Members
  • PipPipPip
  • 49 posts

Posted 10 March 2011 - 03:50 PM

The README txt file refers to version 1.9.0. Is it still OK to use this update utility to update to 2.1.0, or are the update files wrong as well?

#16 Jodes

Jodes

    Novice

  • Members
  • PipPip
  • 34 posts

Posted 10 March 2011 - 08:00 PM

for the record, I ended updoing what DonH suggestion (sort of). Loaded the new version from scratch and using the old version to check settings etc. I haven't been able to find any new manuals for the new version (above 2.0) or anything (I use those rather than the readme file).

#17 phil4v19

phil4v19

    Devotee

  • Members
  • PipPipPipPip
  • 123 posts

Posted 10 March 2011 - 09:18 PM

It appears to be the 2.1 update

However I get when I run it
---------------------------------------------------------------
FATAL ERROR:
update_200E_9671_210E_10169_db::execQueriesFromFile() 1062 Duplicate entry '14-3' for key 'IDX_pid_aid'
---------------------------------------------------------------



The README txt file refers to version 1.9.0.
Is it still OK to use this update utility to update to 2.1.0, or are the update files wrong as well?



#18 wbd

wbd

    Expert

  • Members
  • PipPipPipPipPip
  • 235 posts

Posted 11 March 2011 - 07:32 AM

It appears to be the 2.1 update

However I get when I run it
---------------------------------------------------------------
FATAL ERROR:
update_200E_9671_210E_10169_db::execQueriesFromFile() 1062 Duplicate entry '14-3' for key 'IDX_pid_aid'
---------------------------------------------------------------



I get a similar error when updating vrom v2.0.0 on my development machine (which is a replica of the production env.):
---------------------------------------------------------------
FATAL ERROR:
update_200E_9671_210E_10169_db::execQueriesFromFile() 1062 Duplicate entry '171-4' for key 2
---------------------------------------------------------------


#19 Oleg

Oleg

    Avactis Team Member

  • Administrators
  • PipPipPipPipPipPip
  • 510 posts

Posted 11 March 2011 - 09:54 AM

I'm sorry for the inconvenience.

We fixed all these issues in new update utility version.

Please download update utility once again here: https://www.avactis....port.php?dl=upd

#20 ava2011

ava2011

    Novice

  • Members
  • PipPip
  • 27 posts

Posted 11 March 2011 - 10:51 AM

I have a problem too getting this message:

ShoppingCart Block: Fatal Errors
Error Code Error Source
CORE_0155
File: /avactis-system/admin/blocks_ini/../../../avactis-themes/system/catalog/shopping-cart/default/shopping-cart-config.ini
Section: [CartPreview]
Directive: TemplateFile-Item-Default
Message: Missing declaration of directive TemplateFile-Item-Default.



I'm sorry for the inconvenience.

We fixed all these issues in new update utility version.

Please download update utility once again here: https://www.avactis....port.php?dl=upd



I have 2.1 now, can I do the update again ? Or have to reload 2.0 and update with the new update utility version ?