Jump to content


Photo

Authorize.net error - only on sets of items?!


  • Please log in to reply
6 replies to this topic

#1 athein

athein

    Novice

  • Members
  • PipPip
  • 35 posts

Posted 02 March 2009 - 05:30 PM

I"m receiving this error: The line item [item number] is invalid. A value submitted in x_line_item for the item referenced is invalid There are no odd characters in the product title, etc, yet no one can order these 4 products. Can you tell me where in the db or files i can fix? Thanks, Andrea

#2 Snow Media Inc

Snow Media Inc

    Novice

  • Members
  • PipPip
  • 13 posts

Posted 24 March 2009 - 04:14 PM

I am getting the exact same error. We are using Authorize.net too. We had two Florida customers report this same error... "The line item [item number] is invalid. A value submitted in x_line_item for the item referenced is invalid." Can anyone provide some insight to what the issue could be and how to fix this? thanks!

#3 athein

athein

    Novice

  • Members
  • PipPip
  • 35 posts

Posted 24 March 2009 - 04:34 PM

I paid support to fix. It was something about the Product name being to long. Try to shorten, dump cache, then run a purchase... if not, support was able to fix it in a jif.


I am getting the exact same error. We are using Authorize.net too. We had two Florida customers report this same error...

"The line item [item number] is invalid. A value submitted in x_line_item for the item referenced is invalid."

Can anyone provide some insight to what the issue could be and how to fix this?

thanks!



#4 Marco

Marco

    Avactis Team Member

  • Administrators
  • PipPipPipPipPip
  • 308 posts

Posted 25 March 2009 - 07:45 AM

Hi, Authorize.Net does not accept product names longer than 31 characters. Our developers have already added a function that strips long names before sending them to Authorize.Net. It is included in the new build so please update when it is released (you should receive the newsletter).

#5 jetblab

jetblab

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 11 July 2009 - 10:20 PM

I have the newest version of the shopping cart error but I received this error on an order tonight (7-11-09). Am I allowed to have a hyphen in the product title? like "t-shirt"

#6 Marco

Marco

    Avactis Team Member

  • Administrators
  • PipPipPipPipPip
  • 308 posts

Posted 13 July 2009 - 03:41 AM

This error has been fixed in build 6241. If your build number is less than that, please update your store.

#7 AlexS

AlexS

    Novice

  • Members
  • PipPip
  • 18 posts

Posted 24 July 2009 - 02:18 AM

Besides length of text, you also cannot have "?" at the end of your product name as I found out the hard way ...